FIX PROBLEEM: Teie server töötab PHP versioon, kuid WordPress 5.1.6 3.2.1 5.2.4 vaja vähemalt.

Teade kõik ei ole hästi teada, et paigaldama või tegema upgradeEt uuem versioon 3.2On vaja, et paigaldada uuemat versiooni 5.2.4.

Kui server on paigaldada PHP versioon on vanem kui 5.2.4, paigaldus versioon WordPress 3.2.1Ilmub viga / Message "Teie server töötab PHP versioon WordPress 5.1.6 3.2.1 kuid nõuab vähemalt 5.2.4".
Probleemi saab lahendada väga lihtsalt tõstes PHP, kuid enne seda mõned asjad tuleb arvestada. Esiteks uuendada PHP on võimalik virtuaalserver. Nii saab teha upgrade peavad teil juurdepääs serverile (Dedicated Server või VPS). Teises, enne upgrade peaks dokumenteerima ja olema teadlik, et uus versioon PHP mitte anda vigu teiste alade võõrustas et server.

For operatsioonisüsteemi kasutatakse veebiserverite (Agreart ja / WHM) Näitab teile, kuidas seda teha uuendate PHP CentOS 5.2.10.x 5 32-bit.

Upgrade PHP CentOS 5.1.x 5.2.x et 5.x 32-bit

1. Kontrollige pakendid / moodulid on paigaldatud PHP (näiteks php-mcrypt) lisaks standard Packet. Kui need on olemas, siis kustutatakse või actuzlizate.

Kontroll paigaldatud pakette:

rpm-qa | grep php

old_php_version

2. Et lisada lisareposid Nõutav upgradeOn PHP versioon.

nano / etc / yum.repos.d / CentOS-Testing.repo

Uus fail (CentOS-Testing.repo) Kas lisada järgmised read (copy / paste):

[C5 testimise]
name = CentOS-testimine 5
http://dev.centos.org/centos/ baseurl = $ releasever / testimise / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X faili salvestamiseks CentOS-Testing.repo.

3. Värskenda PHP kaudu yum:

yum uuendus

4. Restart / httpd :

teenus httpd restart

Pärast uuesti httpd ja kontrollige versioon installitud pakette:

new_php_version

Saate vead modules / pakette:

php-v

- PHP Upgrade / CentOS 32-bit (i386).

FIX PROBLEEM: Teie server töötab PHP versioon, kuid WordPress 5.1.6 3.2.1 5.2.4 vaja vähemalt.

Andmeid autor

stealth LP

Asutaja ja toimetaja stealth seadedIn 2006 kuupäeva.
Kogemused Linux operatsioonisüsteemides (eriti CentOS), Mac OS X, Windows XP> Windows 10 ja WordPress (CMS).

Jäta kommentaar