[Fix phpMyAdmin] Konfiguratsioonifail vajab nüüd salajast võtmesõna (blowfish_secret)

Kas see on installitud phpMyAdmin server Ubuntu, CentOS või jne Fedora jaotus, teade "Konfiguratsioonifaili vajab nüüd salajast võtmesõna (blowfish_secret)"Punase indeksi allosas annab see peavalu. Eriti kui seadistatakse õigesti "/etc/phpMyAdmin/config.inc.php".
Muidugi võib tee erineda ühelt konfiguratsioonist teise, kuid see võib olla erinev 7 CentOS cu phpMyAdmin paigaldatud kaudu "yum"In"remi.repo"Config fail asuma" / etc / phpMyAdmin / ".

Olgu, vaatame, kuidas me lahendame "Konfiguratsioonifaili vajab nüüd salajast võtmesõna (blowfish_secret)"Kui sisse config.inc.php meil on see rida:

$ Cfg [ 'blowfish_secret'] = '$ gNsWq $% #% #% EDFSsffsegbVp6LCJw6w'; / * Peate sisestama KÄESOLEVA küpsiste AUTH! * /

Kui see liin on olemas ja meil on "võti" üle 32 tähemärki phpMyAdmin punane kiri peaks kaduma.
Juhul, kui see ei juhtu, siis peaks kustutada küpsised oma brauserist ja välja logida phpMyAdmin. Järgmisel sisselogimisel teade "Konfiguratsioonifaili vajab nüüd salajast võtmesõna (blowfish_secret)"Ma ei saa praegu.
Kuigi leidub olukordi, kus see esineb ei tulene väärkonfiguratsioone faili config.inc.php, kuid selle tõttu kaustaõiguste, kui ta oli.

Jooks terminali käsurida:

 chown -R root: <kasutajaveeb> / etc / phpMyAdmin /

Nüüd peaks kõik olema korras. Kui kasutate Apache'i "kasutajaveebi" asemel, määrake "httpd", "nginx" või kuidas teil on veebiprotsessi kasutaja serveris.

Kirjutasin selle vihjeid, sest ma kedratud üle 2 tundi kogu phpMyAdmin config, ja ikka ei pääse teade: Konfiguratsioonifail vajab nüüd salajast võtmesõna (blowfish_secret). Pärast lahendatud load / rühmad, kadus.

[Fix phpMyAdmin] Konfiguratsioonifail vajab nüüd salajast võtmesõna (blowfish_secret)

Andmeid autor

stealth LP

Asutaja ja toimetaja stealth seadedIn 2006 kuupäeva.
Kogemused Linux operatsioonisüsteemides (eriti CentOS), Mac OS X, Windows XP> Windows 10 ja WordPress (CMS).

3 Kommentaarid

Jäta kommentaar