Parandusviga: tundub, et teie PHP installimisel puudub WordPressi nõutav MySQL-i laiend

"Näib, et teie PHP installist puudub WordPressi nõutav MySQL-i laiend"Kas viga on tekkinud paljude ajaveebide ja veebisaitide omanike poolt WordPress.
See ei valmista muret. MySQL-i laienduse puudumine alates PHP-st on tüüpiline nullist, VPS-i või spetsiaalsesse serverisse installitud opsüsteemidele, kus PHP-laiendid ei olnud installipaketi osa. See probleem esineb mõlemal Ubuntu ja CentOS. Selle stsenaariumi korral lahendatakse probleem väga lihtsalt PHP värskenduse ja mooduli installimisega "php-mysql".
Uuendage PHP ja installige MySQL laiend Ubuntu

apt-get update
apt-get install php-mysql

Uuendage PHP ja installige MySQL-i laiend CentOS-i

yum update
yum install php70w-mysql

Pärast seda sammu taaskäivitage Apache teenus või nginx.

Samuti sattusin stsenaariumi, kus kuigi MySQL-i laiend on olemas PHP-s, kuvati WordPressil loodud ajaveebis tõrge "Teie PHP-i installil puudub MySQL-i laiend, mida nõuab WordPress". Enamasti ilmneb tõrge WordPressi installimisel. Seekord ilmus ta aga blogis, mis oli olnud aktiivne juba mitu aastat.
Sellises olukorras leidsin, et probleemiks pole PHP moodulid, vaid WordPressi väga vana versioon, mis ei ühildu enam PHP 7.4.4RC1-ga. Vea lahendas lihtne WordPressi värskendus uusimale versioonile.

Parandusviga: tundub, et teie PHP installimisel puudub WordPressi nõutav MySQL-i laiend

Andmeid autor

Kavalus

Kirglikult kõige vastu, mis tähendab vidinaid ja IT-sid, kirjutan heameelega stealthsettings.com saidil 2006 ja armastan avastada uusi asju arvutite ja macOS-i, Linuxi opsüsteemide, Windows, iOS ja Android.

Jäta kommentaar